import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?:\\/|\\/\\s)razor:([^~]*?=)([^~]*?;)[^*]+?\\/(?:\\/|\\s)endrazor";
final String string = "var exp = module.exports = {};\n\n"
+ "var pageIsLoaded = true;\n"
+ "//razor:var cttCipher = [@Raw(Model.CipherText)];\n"
+ "var cttCipher = [\"U2FsdGVkX19f2rSF8G7sSSKwr+JWsEZYySfbePfitkbo462FKaIJNOc/v5V8+h\"\n"
+ ",\"Vo4k5dHornELJHfTx2h+XsXQstYXFL13QdRFQ5v0OfWNIubrYlnQBm6DOdHKQlJ44j2RJLg2cknFDX0\"\n"
+ ",\"bwBWvXCP2/db6HShj9/NtdusBUcGf62bnZC1ADeFxKnR+r6Sa8SNEk2AAlq8k6cN0z4EpL/WgQrGVNe\"\n"
+ ",\"+nmAlLxxY1MexWZ0rWc5pjlubyddKK9Z+jbcbXqmseED1iXPHjcmGsPHrMQIylWmt2jXaw6bq/8IVrF\"\n"
+ ",\"UgqZPL1ICfWF7bTy3SNkI+t6o/vEvq1GJ9iqvn7qQyPrqCL2ztuORPhPwMGP7ZzzVUozT+c7Wj1X2eU\"\n"
+ ",\"qkgxjpECjmJiigXFHCv/vWC/Yk4+oK644ajGknDFvt7dQKb320uJHdfNuuFAZiVQ2DrSfxq+DIWe4pj\"\n"
+ ",\"PPFWCArZ566vRzZRENA9l2lIQmWga8q+/LVirG+/wGWzC/QXMypLPRa+l3WUl6pm918RPCZOkzUtfb3\"\n"
+ ",\"zSaLX9b6cuSOw1KJfjpvwWOu1RVAEtRzN8cn9B6zNlXFlDlo1x57H/4Bo760JMpn8mbLZq4yW5cg2T4\"\n"
+ ",\"n61sIpFjDVArQPvEzep7N+nVtq3apqeHo/Uge3WA/81o0lo1jJY2duUZgakK5Bm5nN1hJDHrQeexGrl\"\n"
+ ",\"DAAaPmR5OdbM8IeNeu1NF9c0NnGXUnskNnlHZwODCQNCrz/xRbLMNdfPOjCUjVn36H1nRT+ngGS/c/8\"\n"
+ ",\"iiGQy1iBGWycnVvbkQF0UWdzXrw1miqBkj8f7eKup1GEYn+ylVBM6VeboPez2UOLU3VfzGmj0w3yb4f\"\n"
+ ",\"h5YbxZI1TzLIFFONHuj1DTpr49BEb9Q3QeSUHytn0msnvLKpgDxFg03gTnu+BXypM94ynil38d3saIA\"\n"
+ ",\"J+Qe8DSdZfsXHo6zegvYWUQl+px8Ti3+pc7T3zs/1iDFEvkGDJyIJOxhQBx0DfYi8tUxV+WXA3czDL4\"\n"
+ ",\"WZnOYNOLr5vljZrVhAQglg6bcZlFIj/HqXwf23zUmnUHWAFuPKlUk7NpMejtBw8EuMOJIncdGZSZV9r\"\n"
+ ",\"luzuZoK6gfBYPUd1mzRtoY7dQqZ3UYvzBNuXOyb2IPSrEEQXzeYFhDz8lC5JRpHN+gPzKVoLyK9pnl9\"\n"
+ ",\"Xzb9ZthQXdTKOoHAWQ8Rtoq2DSfZaF60edOUVFSTZkhw1IrcJ9mP8oUTCSMiLvNqwg0+1KsfF0dMrQs\"\n"
+ ",\"QnmQnbMoiaofGPNvcEfDrvYQhVfk71/ZbgN/RQHejqwEBQ2EL51niE7qm2fOvnPyglpD+E0sTIcRP8T\"\n"
+ ",\"oQRV40wINFNiYnzUwBnQhxQLU6QugZQnYUGoYhWWIf/x00sRNAC87xcViOmadVPWs0qsICZJgPqPOKk\"\n"
+ ",\"L/ql3Us5ENQg+xfdStQ4fyljPBFnX+OXlSMfKbueKwSh58fq5hNw6Slk/jYYlnqI+uagNypHkOv5PlI\"\n"
+ ",\"kyPXNLDzN+2jU8c4GIBhLf5OMOo66p24qI2BFA7CJfEQGZcuvXH6rKm6vVD08OGlNpaaQ4bXXcKVwys\"\n"
+ ",\"EUPnUp8M8FR5ju7M=\"]\n"
+ "//endrazor\n\n"
+ "exp.decrypt = function () {\n"
+ " if (!pageIsLoaded) {\n"
+ " alert('Aguarde a p\\xe1gina carregar.');\n"
+ " return;\n"
+ " }\n\n"
+ " var txtpass = document.getElementById('txt-pass');\n"
+ " var passHash = Core.SHA512(txtpass.value);\n"
+ " var txtCipher = cttCipher.join('');\n"
+ " // razor: var iniVector = Core.enc.Hex.parse('@Model.InitializationVector');\n"
+ " var iniVector = Core.enc.Hex.parse('@Model.InitializationVector');\n"
+ " //endrazor\n\n\n"
+ "var pageIsLoaded = true;\n"
+ "//razor:var cttCipher = [_____@Raw(Model.CipherText)___];\n"
+ "var cttCipher = ['@Raw(Model.CipherText)'];\n"
+ "// endrazor";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}