# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<protocol>https?|ftp):\\/\\/(?<domain>[-A-Z0-9.]+)(?<file>\\/[-A-Z0-9+&@#\\/%=~_|!:,.;]*)?(?<parameters>\?[A-Z0-9+&@#\\/%=~_|!:,.;]*)?//gmi;t' <<< "http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/"