package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)(?<file>\/[-A-Z0-9+&@#\/%=~_|!:,.;]*)?(?<parameters>\?[A-Z0-9+&@#\/%=~_|!:,.;]*)?`)
var str = `http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}