$re = '/>\s*\K(?:(?!<).)+(?=<\/li)/';
$str = '<li class="video_description"><strong>Description:</strong> hello world, This is test description.</li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);