using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\{)(?!\s*\{)[^{}]+";
string input = @"{ { ""John"", ""ran"" }, { ""NOUN"", ""VERB"" } },
{ { ""The"", ""dog"", ""jumped""}, { ""DET"", ""NOUN"", ""VERB"" } },
{ { ""Mike"",""lives"",""in"",""Poland""}, {""NOUN"",""VERB"",""DET"",""NOUN""} },";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}