re = /(?<=\{)(?!\s*\{)[^{}]+/
str = '{ { "John", "ran" }, { "NOUN", "VERB" } },
{ { "The", "dog", "jumped"}, { "DET", "NOUN", "VERB" } },
{ { "Mike","lives","in","Poland"}, {"NOUN","VERB","DET","NOUN"} },'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end