$re = '/[#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])/m';
$str = '#8, #6, #3, #9, #16';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);