$re = '/^([a-z]1[a-z]54)?$/m';
$str = 'a1w54
b1s54';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;