#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " (?! )"
Local $sString = "T E S T R E N T A L A K T I E B O L A G"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)