using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?! )";
string substitution = @"_";
string input = @"T E S T R E N T A L A K T I E B O L A G";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}