const regex = /^[\p{L}\p{M}\p{N}\p{P}\p{C}\p{Z}\p{S}][^=@]+$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{L}\\p{M}\\p{N}\\p{P}\\p{C}\\p{Z}\\p{S}][^=@]+$', 'u')
const str = `asdas asdasdas dasdas das d/asd asdaasd #˝˝¥ʼ¯ˍ˙œß¯`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}