re = /^[\p{L}\p{M}\p{N}\p{P}\p{C}\p{Z}\p{S}][^=@]+$/
str = 'asdas asdasdas dasdas das d/asd asdaasd #˝˝¥ʼ¯ˍ˙œß¯'
# Print the match result
str.match(re) do |match|
puts match.to_s
end