package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)=([^=]*\w)(?:\s|$)`)
var str = `start=Mar 26 2019 10:36:14 +00:00 end=Mar 26 2019 10:36:14 +00:00 suser=AD.COM\\Username src=10.1.0.51`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}