re = /(\w+)=([^=]*\w)(?:\s|$)/m
str = 'start=Mar 26 2019 10:36:14 +00:00 end=Mar 26 2019 10:36:14 +00:00 suser=AD.COM\\\\Username src=10.1.0.51'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end