$re = '/\[[^\]]+-[^\]]+\]/';
$str = 'A long string containing square brackets [some-name]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);