re = /\[[^\]]+-[^\]]+\]/
str = 'A long string containing square brackets [some-name]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end