using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\[[^\]]*\]";
string substitution = @"";
string input = @"Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}