use strict;
my $str = 'Hi [everybody], I\'m 22 years old, I\'m a student [at a University of Technology] in Vietnam
';
my $regex = qr/\s+\[[^\]]*\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";