package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)[\w-]+\.[\w-]+`)
var str = `some.prefix.xyz.xyz
some.prefix.xyz
abc.def.csv.gz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}