$re = '/^(?i)[\w-]+\.[\w-]+/m';
$str = 'some.prefix.xyz.xyz
some.prefix.xyz
abc.def.csv.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);