import re
regex = re.compile(r"(\[trx[^\]]+.)|(\[\/trx[^\]]+.)|(<a[^>]+.)|(<img[^>]+.)(<[^>]+.)")
test_str = ("[trx_columns autoheight=\"no\" indentation=\"yes\" count=\"2\"][trx_column_item width=\"40%\"]\n"
"<table>\n"
"<tbody>\n"
"<tr>\n"
"<td width=\"96\">Suprafaţa</td>\n"
"<td width=\"96\">39 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\">Bucătărie</td>\n"
"<td width=\"96\">9,2 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\">Odaie</td>\n"
"<td width=\"96\">19.3 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\">Antreu</td>\n"
"<td width=\"96\">4.3 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\">Bloc sanitar</td>\n"
"<td width=\"96\">3.3 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\">Balcon</td>\n"
"<td width=\"96\">2.9 m²</td>\n"
"</tr>\n"
"<tr>\n"
"<td width=\"96\"><strong>Preţ total</strong></td>\n"
"<td width=\"96\"><strong>20 475 €</strong></td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"[/trx_column_item][trx_column_item ]<a href=\"http://teatral.md/wp-content/uploads/2015/08/39.jpg\"><img class=\"alignnone size-medium wp-image-4147\" src=\"http://teatral.md/wp-content/uploads/2015/08/39-225x300.jpg\" alt=\"39\" width=\"225\" height=\"300\" /></a>[/trx_column_item][/trx_columns]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)