package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)(facet|map)(.*)(map|facet)(.*)$`)
var str = `somethingmapthi
facetthatmap
onlyfacet
nothingishere
nothingaswell
maybemapandmaybefacet
maybefacetandmaybemap
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}