$re = '/^(.*)(facet|map)(.*)(map|facet)(.*)$/m';
$str = 'somethingmapthi
facetthatmap
onlyfacet
nothingishere
nothingaswell
maybemapandmaybefacet
maybefacetandmaybemap
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);