$re = '/^[gG]-\d{2}[a-zA-Z]{3}$|^[gG]-[a-zA-Z]{3}\d{2}$/m';
$str = 'G-31SSD
G-EEE43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);