// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[gG]-\d{2}[a-zA-Z]{3}$|^[gG]-[a-zA-Z]{3}\d{2}$").unwrap();
let string = "G-31SSD
G-EEE43";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}