import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(##[^\\n]*\\n)|(\\((CR|CL) \\d+\\)) ((RM|SM) [0-9]:)|([a-zA-Z]+!?(?: [a-zA-Z]*!?)*)";
final String string = "## (Chat room 1) Received message from client 1: Nice to meet you!\n"
+ "(CR 1) RM 1: Nice to meet you!\n"
+ "(CR 1) SM 1: Nice to meet you!\n"
+ "## (Client 1) Received message from client 1: Nice to meet you!\n"
+ "(CL 1) RM 1: Nice to meet you!\n"
+ "(CR 0) SM 3: Nice to meet you!\n"
+ "## (Client 3) Received message from client 3: Nice to meet you!\n"
+ "(CL 3) RM 3: Nice to meet you!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}