import re
regex = re.compile(r"(##[^\n]*\n)|(\((CR|CL) \d+\)) ((RM|SM) [0-9]:)|([a-zA-Z]+!?(?: [a-zA-Z]*!?)*)", flags=re.MULTILINE)
test_str = ("## (Chat room 1) Received message from client 1: Nice to meet you!\n"
"(CR 1) RM 1: Nice to meet you!\n"
"(CR 1) SM 1: Nice to meet you!\n"
"## (Client 1) Received message from client 1: Nice to meet you!\n"
"(CL 1) RM 1: Nice to meet you!\n"
"(CR 0) SM 3: Nice to meet you!\n"
"## (Client 3) Received message from client 3: Nice to meet you!\n"
"(CL 3) RM 3: Nice to meet you!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")