package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+$`)
var str = `Smth1
Smth22
Smth333
Smth4444
Smth55555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}