$re = '/[0-9]+$/m';
$str = 'Smth1
Smth22
Smth333
Smth4444
Smth55555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);