re = /1?[\ \.\(]?[N]{3}\)?[]\ \-\.][A][N]{2}[\ \-\.][N]{4}\)?/
str = 'NNN ANN NNNN
(NNN) ANN NNNN
NNN-ANN-NNNN
(NNN) ANN-NNNN
1NNN ANN NNNN
1(NNN) ANN NNNN
1NNN-ANN-NNNN
1(NNN) ANN-NNNN
NNN.ANN.NNNN
(NNN-ANN-NNNN)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end