$re = '/^[A-Z][a-z]+\s[A-Z][a-z]+$/m';
$str = 'John Smith
John Smith Joe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);