// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[.,?!'"]+|[.,?!'"]+$"#).unwrap();
let string = "'Hello world, josh's car.,'
Hello World.......
..,!Bye World
.???'\"\"\"Again, what message should I type here!!!";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}