const regex = /((((http|https):\/{2})|www\.)+(([0-9a-z_-]+\.)+([0-9a-z_-]+)(:[0-9]+)?((\/([~0-9a-zA-Z\#\+\%@\.\/_-]+))?(\?[0-9a-zA-Z\+\%@\/&\[\];=_-]+)?)?))/ium;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((((http|https):\\\/{2})|www\\.)+(([0-9a-z_-]+\\.)+([0-9a-z_-]+)(:[0-9]+)?((\\\/([~0-9a-zA-Z\\#\\+\\%@\\.\\\/_-]+))?(\\?[0-9a-zA-Z\\+\\%@\\\/&\\[\\];=_-]+)?)?))', 'ium')
const str = `www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}