const regex = /<\?php(.+?)\?>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\?php(.+?)\\?>', 'i')
const str = `<?php some code in here ?> <?php some other code in here ?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}