$re = '/^(09|\+639)\d{9}$/m';
$str = '+639123456789
09123456789
asd
12341234
+63912345
0913456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);