import re
regex = re.compile(r"^(09|\+639)\d{9}$", flags=re.MULTILINE)
test_str = ("+639123456789\n"
"09123456789\n"
"asd\n"
"12341234\n"
"+63912345\n"
"0913456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")