#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\["(Total|Group1|Group2)",(\d+),\d*,,,,,\d+,\d+\]"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html class="main">" & @CRLF & _
" <head>" & @CRLF & _
" <meta http-equiv="content-type" content="text/html; charset=utf-8" />" & @CRLF & _
" <title>Test_Results_20240621_0910</title>" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/jquery-1.3.2.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/jquery.ui.custom-1.8.7.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/jquery.dynatree-1.2.4.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/jquery.cookie-1.3.1.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/jquery.splitter-1.5.1.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="Test_Results_20240621_0910/js/dotcover.report.js"></script>" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="Test_Results_20240621_0910/css/dotcover.report.css">" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="Test_Results_20240621_0910/css/dotcover.report.gen.css">" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="Test_Results_20240621_0910/css/jquery.dynatree.css">" & @CRLF & _
" </head>" & @CRLF & _
"" & @CRLF & _
" <body>" & @CRLF & _
" <div class="header"><span class="title">Test_Results_20240621_0910 Coverage Report</span><span class="info">Generated: Friday, June 21, 2024 09:14:13</span></div>" & @CRLF & _
" <div class="content" id="content"><div id="coverageTree"></div><iframe id="sourceCode"></iframe></div>" & @CRLF & _
" <div class="footer">JetBrains dotCover 2024.1.3 Copyright © 2010-2024 <a href="https://www.jetbrains.com/dotcover/" target="_blank">Product Homepage</a> | <a href="https://www.jetbrains.com/feedback/feedback.jsp?product=dotCover&build=3&timezone=Eastern Standard Time" target="_blank">Feedback</a> | <a href="https://www.jetbrains.com/" target="_blank">Company</a></div>" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" var resourceFolder = "Test_Results_20240621_0910";" & @CRLF & _
" var blockSize = 50000;" & @CRLF & _
" block0 = [["Total",47,,,,,,1,2],["Group1",29,0,,,,,3,5],["Group2",52,0,,,,,8,4]];" & @CRLF & _
" coverageData = [block0];" & @CRLF & _
" </script>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")