import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\"(Total|Group1|Group2)\",(\\d+),\\d*,,,,,\\d+,\\d+\\]";
final String string = "<!DOCTYPE html>\n"
+ "<html class=\"main\">\n"
+ " <head>\n"
+ " <meta http-equiv=\"content-type\" content=\"text/html; charset=utf-8\" />\n"
+ " <title>Test_Results_20240621_0910</title>\n\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/jquery-1.3.2.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/jquery.ui.custom-1.8.7.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/jquery.dynatree-1.2.4.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/jquery.cookie-1.3.1.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/jquery.splitter-1.5.1.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"Test_Results_20240621_0910/js/dotcover.report.js\"></script>\n\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"Test_Results_20240621_0910/css/dotcover.report.css\">\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"Test_Results_20240621_0910/css/dotcover.report.gen.css\">\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"Test_Results_20240621_0910/css/jquery.dynatree.css\">\n"
+ " </head>\n\n"
+ " <body>\n"
+ " <div class=\"header\"><span class=\"title\">Test_Results_20240621_0910 Coverage Report</span><span class=\"info\">Generated: Friday, June 21, 2024 09:14:13</span></div>\n"
+ " <div class=\"content\" id=\"content\"><div id=\"coverageTree\"></div><iframe id=\"sourceCode\"></iframe></div>\n"
+ " <div class=\"footer\">JetBrains dotCover 2024.1.3 Copyright © 2010-2024 <a href=\"https://www.jetbrains.com/dotcover/\" target=\"_blank\">Product Homepage</a> | <a href=\"https://www.jetbrains.com/feedback/feedback.jsp?product=dotCover&build=3&timezone=Eastern Standard Time\" target=\"_blank\">Feedback</a> | <a href=\"https://www.jetbrains.com/\" target=\"_blank\">Company</a></div>\n\n"
+ " <script type=\"text/javascript\">\n"
+ " var resourceFolder = \"Test_Results_20240621_0910\";\n"
+ " var blockSize = 50000;\n"
+ " block0 = [[\"Total\",47,,,,,,1,2],[\"Group1\",29,0,,,,,3,5],[\"Group2\",52,0,,,,,8,4]];\n"
+ " coverageData = [block0];\n"
+ " </script>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}