import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=v(\\=|\\/))([-a-zA-Z0-9_]+)|(?<=youtu\\.be\\/)([-a-zA-Z0-9_]+)";
final String string = "http://youtu.be/iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "https://www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related \n"
+ "http://youtu.be/iwGFalTRHDA \n"
+ "http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA\n"
+ "http://www.youtube.com/embed/watch?v=iwGFalTRHDA\n"
+ "http://www.youtube.com/embed/v=iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA\n"
+ "www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "www.youtu.be/iwGFalTRHDA \n"
+ "youtu.be/iwGFalTRHDA \n"
+ "youtube.com/watch?v=iwGFalTRHDA \n"
+ "http://www.youtube.com/watch/iwGFalTRHDA\n"
+ "http://www.youtube.com/v/iwGFalTRHDA\n"
+ "http://www.youtube.com/v/i_GFalTRHDA\n"
+ "http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related \n"
+ "http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA\n"
+ "http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail\n"
+ "http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}