import re
regex = re.compile(r"(?<=v(\=|\/))([-a-zA-Z0-9_]+)|(?<=youtu\.be\/)([-a-zA-Z0-9_]+)")
test_str = ("http://youtu.be/iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA \n"
"https://www.youtube.com/watch?v=iwGFalTRHDA \n"
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related \n"
"http://youtu.be/iwGFalTRHDA \n"
"http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/watch?v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"www.youtube.com/watch?v=iwGFalTRHDA \n"
"www.youtu.be/iwGFalTRHDA \n"
"youtu.be/iwGFalTRHDA \n"
"youtube.com/watch?v=iwGFalTRHDA \n"
"http://www.youtube.com/watch/iwGFalTRHDA\n"
"http://www.youtube.com/v/iwGFalTRHDA\n"
"http://www.youtube.com/v/i_GFalTRHDA\n"
"http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related \n"
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")