#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(^mysql:host=[^;]+;dbname=[^;]+;(?:port=\d{2,4};)?(?:charset=[^;]+;)?$)"
Local $sString = "mysql:host=localhost;dbname=dldl;port=33;charset=utf-8;" & @CRLF & _
"The following example shows a PDO_MYSQL DSN for connecting to MySQL databases:" & @CRLF & _
"" & @CRLF & _
"mysql:host=localhost;dbname=testdb" & @CRLF & _
"" & @CRLF & _
"More complete examples:" & @CRLF & _
"" & @CRLF & _
"mysql:host=localhost;port=3307;dbname=testdb" & @CRLF & _
"mysql:unix_socket=/tmp/mysql.sock;dbname=testdb" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")