import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^mysql:host=[^;]+;dbname=[^;]+;(?:port=\\d{2,4};)?(?:charset=[^;]+;)?$)";
final String string = "mysql:host=localhost;dbname=dldl;port=33;charset=utf-8;\n"
+ "The following example shows a PDO_MYSQL DSN for connecting to MySQL databases:\n\n"
+ "mysql:host=localhost;dbname=testdb\n\n"
+ "More complete examples:\n\n"
+ "mysql:host=localhost;port=3307;dbname=testdb\n"
+ "mysql:unix_socket=/tmp/mysql.sock;dbname=testdb\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}