const regex = /[^"]*\./gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^"]*\\.', 'gi')
const str = `name="2-columns.Heading-1"
name="3-columns.Heading-1"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);