$re = '/[^"]*\./i';
$str = 'name="2-columns.Heading-1"
name="3-columns.Heading-1"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;