$re = '/^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d).{6,12}$/m';
$str = 'afdfsdfsdfdsfsdfdsfdsfsd
asasasasA122';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);