re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d).{6,12}$/m
str = 'afdfsdfsdfdsfsdfdsfdsfsd
asasasasA122'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end