# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^.0-]|[^.0-][0-9]+|[0])$//gm;t' <<< "111111111111111999999999999999990000000000000000333333333333333332
10
11
2
0
-1
-22
1.4
0.1
0.
0-
-0
000.4
022345
0
"