re = /^([^.0-]|[^.0-][0-9]+|[0])$/m
str = '111111111111111999999999999999990000000000000000333333333333333332
10
11
2
0
-1
-22
1.4
0.1
0.
0-
-0
000.4
022345
0
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result