package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:[^:]*$`)
var str = `sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/#query2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}