re = /https?:[^:]*$/
str = 'sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/#query2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end